Additional Info
Type
Package ID
brettflan:polls_can_block_new_
First Created
May 18, 2010, 08:43:36 PM
Last Updated
June 20, 2011, 11:41:11 PM

Polls Can Block New Users v1.2

option to prevent user accounts created after a poll from voting in it
Compatible With 2.0 RC3, 2.0 RC4, 2.0 RC5, 2.0
Latest version v1.2
Downloads 1,149
Reviews 0
Rating 0/5
Subscribers 4
License (View License)
Author(s)
This modification will add two new options when creating a poll, to optionally prevent user accounts created after the poll from voting in it. This new poll option will only be available to moderators and administrators. The first option given is whether to prevent newer users from voting (disabled by default), and the second option is the exact Unix timestamp to use. The timestamp defaults to the current time when the page loads, so you normally shouldn't need to alter that value.
Users whose accounts were created after that timestamp will get an error message when they try to vote indicating as much, and the vote will of course not go through.

To change the messages given, simply edit the "PollBlockNewUsers.english.php" file (or other appropriate non-'english' language file). UTF-8 and ISO-8859-1 language files for English and Spanish Es are included.

Note: this mod was done on commission for videoed, and is being made publicly available with his blessing.
Manual installation info
You have to register or login to be able to leave a review
There are currently no reviews on this customization
Advertisement: